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GIỚI THIỆU 

OpenOffice.org Calc là phần mềm bảng tính thuộc bộ phần mềm 
OpenOffice.org được phát triển bởi Sun Microsystems và cộng đồng mã 
nguồn mở. OpenOffice.org có thể chạy trên nhiều hệ điều hành và hỗ trợ 
đa ngôn ngữ, trong đó có cả phiên bản tiếng Việt.  

OpenOffice Calc có tính năng tương tự về mặt giao diện và cách sử 
dụng như Microsoft Office Excel, dễ học và dễ sử dụng. OpenOffice.org 
Calc ngày càng được ưa chuộng và sử dụng rộng rãi bởi tính hiệu quả 
cao trong công việc. Phần mềm OpenOffice.org Calc được giới thiệu 
trong tài liệu này là phiên bản 2.2. 

Lần đầu làm quen với phần mềm, cách học nhanh nhất là đọc hết 
tài liệu, sau đó tiến hành thực hành ngay trên máy tính khi kết thúc mỗi 
chương, nếu có vấn đề khúc mắc người sử dụng tra cứu lại tài liệu để 
hiểu rõ ràng hơn. Đối với người dùng đã có kinh nghiệm sử dụng phần 
mềm Microsoft Office Execl, tài liệu này có giá trị để tra cứu trong quá 
trình sử dụng. 

Nội dung cuốn sách gồm 7 chương và 2 phần 

♦ Chương 01: Làm quen với Calc 

♦ Chương 02: Các thao tác với bảng tính 

♦ Chương 03: Xử lý dữ liệu trong bảng tính 

♦ Chương 04: Hàm trong Calc 

♦ Chương 05: Đồ thị 

♦ Chương 06: Quản trị dữ liệu 

♦ Chương 07: Trình bày trang và in 

♦ Bài tập thực hành 

♦ Phụ lục: Những khách nhau cơ bản giữa Calc và Excel 
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Chương 01 

LÀM QUEN VỚI CALC 

1.1 Cách khởi động 

Có rất nhiều cách có thể khởi động được phần mềm Calc. Tuỳ vào 
mục đích làm việc, sở thích hoặc sự tiện dụng mà ta có thể chọn một 
trong các cách sau đây để khởi động: 

Cách 1: Chọn lệnh Start của Windows: Start → Programs → 
OpenOffice.org 2.2→ OpenOffice.org Calc 

Cách 2: Nháy kép chuột lên biểu tượng của phần mềm Calc nếu 
như nhìn thấy nó bất kỳ ở chỗ nào trên  màn hình nền của Windows, v.v.. 

Cách 3: Nếu muốn mở nhanh một tệp văn bản vừa soạn thảo gần 
đây nhất trên máy tính đang làm việc, có thể chọn Start → Documents, 
chọn tên bảng tính (Calc) cần mở. Khi đó Calc sẽ khởi động và mở ngay 
bảng tính vừa chỉ định. 

1.2 Màn hình làm việc của Calc 

Sau khi khởi động, màn hình làm việc của Calc có dạng như sau: 

 
Hình 1. Màn hình chính của OpenOffice.org Calc 
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- Thanh tiêu đề (Title bar): ở dòng trên cùng của màn hình, khi mới 
khởi động Calc tại đây ghi Untitled1 -OpenOffice.org Calc, khi ta đặt tên 
cho bảng tính, tên này kèm theo phần mở rộng .ODS sẽ thay thế từ 
Untitled1. 

- Các thanh Menu, Công cụ, Định dạng, giống như trong phần mềm 
Writer. Phần lớn biểu tượng trên các thanh này có công dụng ý nghĩa 
như trong Writer. 

- Thanh công thức: Là dòng thứ 5 của màn hình hiển thị tọa độ (địa 
chỉ hoặc ô tên) ô, nút hủy bỏ, nút lựa chọn, nội dung dữ liệu trong ô hiện 
tại (ô có khung viền chung quanh). 

- Thanh trạng thái (Status bar): Là dòng cuối cùng hiển thị các chế 
độ hoạt động của Calc. 

- Thanh thẻ tên bảng tính (Sheet bar): Là thanh nằm ngay trên thanh 
trạng thái, hiển thị tên của các bảng tính.  

- Cột (Column): Là tập hợp các ô trong bảng tính theo chiều dọc 
được đánh thứ tự bằng chữ cái (từ trái sang phải bắt đầu từ A, B, C ... 
AA, AB đến IV, tổng số có 256 cột). Ngoài cùng bên trái là nút chọn 
(đánh dấu khối) toàn bộ bảng tính. 

- Hàng (Row): Là tập hợp các ô trong bảng tính theo chiều ngang 
được đánh thứ tự bằng số từ 1 đến 16.384 

- Ô (Cell): Là giao của một cột và một hàng. Địa chỉ của ô được xác 
định bằng cột trước, hàng sau, ví dụ C4, A23. 

- Ô hiện tại: Là ô có khung viền chung quanh với một chấm vuông 
nhỏ ở góc dưới (Mốc điền) hay còn gọi là Con trỏ ô (sau này gọi là con 
trỏ). Tọa độ của ô này được hiển thị trên thanh công thức. 

1.3 Thoát khỏi giao diện Calc 

Khi không muốn làm việc với Calc nữa, bạn có thể thực hiện theo 
một trong các cách sau: 

- Mở Menu File → Exit hoặc nhấn tổ hợp phím tắt Alt + F4.
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Chương 02 

CÁC THAO TÁC VỚI BẢNG TÍNH 

2.1 Tạo một bảng tính mới 

Làm việc với Calc là làm việc trên các bảng tính. Mỗi bảng tính 
phải được lưu lên đĩa với một tệp tin có phần mở rộng .ODS. Thông 
thường sau khi khởi động Calc, một màn hình trắng xuất hiện. Đó cũng 
là bảng tính mới mà Calc tự động tạo ra. Tuy nhiên để tạo một tài liệu 
mới, bạn có thể sử dụng một trong các cách sau: 

- Mở mục chọn File → New..; 

hoặc 

- Nhấn nút New  trên thanh công cụ Standard; 

hoặc 

- Nhấn tổ hợp phím tắt Ctrl + N. 

2.2 Lưu bảng tính lên đĩa 

Thường thì các tệp tài liệu của bạn sẽ được lưu vào thư mục C:\My 
Documents trên đĩa cứng. Tuy nhiên, bạn có thể thay đổi lại thông số 
này khi làm việc với Calc. 

Để lưu bảng tính đang làm việc lên đĩa, bạn có thể chọn một trong 
các cách sau: 

- Mở mục chọn File → Save..; 

hoặc 

- Nhấn nút Save  trên thanh công cụ Standard; 

hoặc 

- Nhấn tổ hợp phím tắt Ctrl + S. 

Sẽ có hai khả năng xảy ra: 

Nếu đây là bảng tính mới, hộp thoại Save As xuất hiện, cho phép 
lưu bảng tính này bởi một tệp tin mới: 
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Hình 2. Hộp thoại Save As 

Hãy xác định thư mục (Folder) nơi sẽ chứa tệp tin mới này rồi gõ 
tên tệp tin vào mục File name (ví dụ: tên file rồi nhấn nút Save để kết 
thúc việc ghi nội dung tài liệu). 

Nếu bảng tính của bạn đã được lưu vào một tệp, khi ra lệnh cất tất 
cả những sự thay đổi trên tài liệu sẽ được ghi lại lên đĩa. 

Chú ý: Bạn nên thực hiện thao tác ghi tài liệu thường xuyên trong 
khi soạn tài liệu, để tránh mất dữ liệu khi gặp các sự cố mất điện, hay 
những trục trặc của máy tính. 

2.3 Mở tài liệu đã tồn tại trên đĩa 

Bảng tính sau khi đã thực hiện trên Calc được lưu trên đĩa dưới 
dạng tệp tin có phần mở rộng là .ODS. Để mở một bảng tính đã có trên 
đĩa, bạn có thể chọn một trong các cách sau đâu: 

- Mở mục chọn File → Open hoặc nhấn tổ hợp phím tắt Ctrl+O. 
Hộp thoại Open xuất hiện: 
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Hình 3. Hộp thoại Open 

Tìm đến thư mục nơi chứa bảng tính cần mở trên đĩa, chọn tệp tài 
liệu, cuối cùng nhấn nút Open để tiếp tục. Tệp tài liệu sẽ được mở ra trên 
màn hình Calc. 

2.4 Đóng bảng tính 

Trước khi chuyển sang bảng tính khác hoặc muốn làm việc với 
bảng tính khác, phải lưu bảng tính lên đĩa sau đó mới đóng nó bằng cách 
chọn File → Close. 

2.5 Chèn thêm một bảng tính 

Chọn Insert → Sheet, hoặc bấm chuột phải lên thanh thẻ tên bảng 
tính chọn Insert Sheet. 

2.6 Xóa một bảng tính 

Chọn Edit → Sheet → Delete, hoặc bấm chuột phải lên thanh thẻ 
tên bảng tính chọn Delete Sheet. 
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2.7 Đổi tên bảng tính 

Chọn Format → Sheet → Rename, hoặc bấm chuột phải lên thanh 
thẻ tên bảng tính chọn Rename Sheet 

2.8 Sao chép/ di chuyển một bảng tính 

 
Hình 4. Hộp thoại Move/Copy Sheet 

Bấm chuột phải lên tên bảng tính cần sao chép/ di chuyển trên 
thanh thẻ tên bảng tính chọn Move/Copy Sheet hộp thoại Move/Copy 
Sheet xuất hiện  

Chọn vị trí cần di chuyển/copy đến nhấn OK để hoàn tất. 

2.9 Ẩn và hiện lại một bảng tính 

- Để ẩn bảng tính Format → Sheet → Hide để ẩn bảng tính 

- Để hiện lại bảng tính chọn Format → Sheet → Unhide. 

2.10 Bảo vệ bảng tính 

Để bảo vệ bảng tính của bạn khỏi sự truy nhập của người khác chọn 
Tools → Protect Document 

 
Hình 5. Hộp thoại Protech Document 
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- Chọn Sheet để bảo vệ bảng tính, chọn Document để bảo vệ tập 
bảng tính,  hộp thoại sau xuất hiện  

Nếu cần thiết gõ mật khẩu vào vùng Password, 2 lần gõ giống nhau 
và phân biệt chữ hoa với chữ thường. 

 
Hình 6. Hộp thoại Unprotech sheet 

Để bỏ tình trạng bảo vệ: Chọn Tools → Protection, chọn Sheet nếu 
bạn bảo vệ bảng tính, Document nếu bảo vệ tập bảng tính. Hộp thoại sau 
xuất hiện 

Gõ lại mật khẩu đã thiết lập, Ấn OK để hoàn tất việc hủy bỏ bảo 
vệ. 

Để bảo vệ không cho người khác mở file Calc của bạn làm như sau: 

Chọn File → Save As hộp thoại Save As xuất hiện 

Đánh dấu vào ô Save with password 

 
Hình 7. Hộp thoại Save As 
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Bấm Save, hộp thoại Enter Password xuất hiện 

 
Hình 8. Hộp thoại Enter Password 

Gõ mật khẩu vào vùng Password, 2 lần gõ giống nhau và phân biệt 
chữ hoa với chữ thường. 

2.11 Chọn nhiều bảng tính 

- Liền kề: Bấm chuột vào thẻ tên đầu, giữ Shift trong khi bấm chuột 
vào thẻ tên cuối 

- Cách nhau: Giữ Ctrl trong khi lần lượt bấm chuột vào các thẻ tên 

- Để bỏ việc chọn một bảng tính nào đó: giữ Ctrl trong khi bấm 
chuột vào thẻ tên của bảng tính đó.
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Chương 03 

XỬ LÝ DỮ LIỆU TRONG BẢNG TÍNH 

3.1 Các kiểu dữ liệu 

Trong một ô chỉ có thể chứa một kiểu dữ liệu, kiểu dữ liệu của ô 
phụ thuộc vào ký tự đầu tiên gõ vào. Các kiểu dữ liệu trong một ô được 
tạo ra như sau: 

3.1.1 Dạng chuỗi (Text) 

- Bắt đầu bởi các chữ cái a đến z hoặc A đến Z 

- Những dữ liệu dạng chuỗi như số nhà, số điện thoại, mã số ... khi 
nhập vào phải bắt đầu bằng dấu nháy đơn (') và không có giá trị tính 
toán. 

- Theo mặc định, dữ liệu dạng chuỗi được căn sang trái ô. 

3.1.2 Dạng số (Number)  

Bắt đầu bởi:  - Các số từ 0 đến 9 

  - Các dấu +, - , *, (, $ (hoặc một dấu đơn vị tiền tệ khác tùy 
thuộc vào việc đặt các thông số quốc tế của Windows) 

- Theo mặc định, dữ liệu dạng số được căn sang phải ô. 

3.1.3 Dạng công thức (Formulas) 

Bắt đầu bởi dấu = sau khi ấn Enter công thức nhập vào chỉ thể hiện 
trên thanh công thức còn kết quả được thể hiện trong ô. 

Nếu thấy Có thể là do: 

#### Cột quá hẹp 

Err:503 Chia cho 0, sai về kiểu của toán hạng 

#NAME? Thực hiện phép tính với một biến không xác định (tên 
không gắn với một ô hay vùng nào cả) 

#N/A  Tham chiếu đến ô rỗng hoặc không có trong danh sách 
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3.1.4 Dạng ngày (Date), giờ (Time) 

Trong cách trình bày dưới đây: 

 DD là 2 con số chỉ ngày 

 MM là 2 con số chỉ tháng 

 YY là 2 con số chỉ năm 

Nhập theo dạng MM/DD/YY hoặc DD/MM/YY tùy thuộc vào việc 
đặt các thông số quốc tế của Windows, ví dụ nếu đặt thông số quốc tế 
kiểu Pháp, ta gõ vào 27/03/07, trường hợp dùng kiểu Mỹ (ngầm định) ta 
gõ vào 03/27/07. Khi nhập sai dạng thức, Calc tự động chuyển sang dạng 
chuỗi (căn sang trái ô) và ta không thể dùng kiểu dữ liệu này để tính 
toán. 

3.2 Các toán tử trong công thức 

3.2.1 Toán tử số 
  

Phép toán Ví dụ 

+ cộng 10 + 5 = 15 

-   trừ 10- 5 = 5 

* nhân 10*50 = 500 

/ chia 90/3 = 30 

^ lũy thừa 3^2 = 9 

%phần trăm 50%*600 = 300 
 

Thứ tự ưu tiên của các phép toán như sau: lũy thừa trước rồi đến 
nhân chia và sau cùng mới đến cộng trừ. Các phép toán ở cùng mức ưu 
tiên (như nhân chia hoặc cộng trừ) thực hiện từ trái sang phải. Muốn thay 
đổi thứ tự ưu tiên, dùng các cặp dấu ngoặc tròn, toán tử trong cặp ngoặc 
ở sâu nhất sẽ được thực hiện trước. 



Hướng dẫn sử dụng OpenOffice.org Calc 
 

 15 

3.2.2 Toán tử chuỗi 

 & Nối chuỗi. 

 Ví dụ: “Tin”&“Học”. Kết quả thu được là: TinHọc 

3.2.3 Toán tử so sánh 
  

> Lớn hơn 

<  Nhỏ hơn 

>= Lớn hơn hoặc bằng

<= Nhỏ hơn hoặc bằng

<> Khác 
  

Các toán tử so sánh cho kết quả là True (Đúng) hoặc False (Sai).  

3.3 Nhập dữ liệu 

3.3.1 Dữ liệu bất kỳ 

- Đưa con trỏ về ô cần thiết 

- Nhập dữ thiệu theo loại dạng thức 

- Để kết thúc việc nhập dữ liệu, làm theo một trong các cách sau: 

+ Ấn phím Enter, con trỏ ô sẽ xuống ô dưới 

+ Ấn một phím mũi tên để đưa con trỏ sang ô cần thiết, ví dụ ấn 
phím → sẽ đưa con trỏ sang ô bên phải. 

+ Trỏ chuột vào ô cần tới, bấm chuột trái. 

3.3.2 Dữ liệu trong các ô tuân theo một quy luật 

Chuỗi số với bước nhảy là 1: 

- Đưa con trỏ về ô đầu tiên của miền, gõ vào số bắt đầu, ví dụ để 
đánh số thứ tự cho một số ô bắt đầu từ 1, ta gõ 1. 

- Trỏ chuột vào mốc điền cho xuất hiện dấu + mầu đen, giữ phím 
Ctrl trong khi kéo và thả chuột tại ô cuối của miền (từ đây về sau ta gọi 
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thao tác này là điền tự động (AutoFill)). Kết quả ta được một chuỗi số 1, 
2, 3 ... 

Chuỗi số với bước nhảy bất kỳ: 

- Đưa con trỏ về ô đầu tiên của miền, gõ vào số bắt đầu, ví dụ để có 
chuỗi số chẵn ta gõ 2 vào một ô nào đó. 

- Về ô dưới (hoặc ô bên phải) của miền, gõ vào số tiếp theo, ví dụ 
ta gõ số 4. 

- Đánh dấu khối 2 ô này, trỏ chuột vào mốc điền cho xuất hiện dấu 
+ màu đen, kéo và thả chuột tại ô cuối của miền. 

Chuỗi ngày tháng tăng: 

- Đưa con trỏ về ô đầu tiên của miền, gõ vào ngày tháng năm bắt 
đầu. 

- Trỏ chuột vào mốc điền cho xuất hiện dấu +, bấm giữ nút phải, 
kéo thả tại ô cuối miền. 

 
Hình 9. Hộp thoại Fill Series 
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- Chọn Menu Edit → Fill → Series hộp thoại Series xuất hiện. 

Trong phần Time unit chọn:  

 Day: Để tăng 1 ngày (ví dụ 28/03/2007, 29/03/2007, 30/03/2007) 

 Month: Để tăng 1 tháng (ví dụ 28/03/2007, 28/04/2007, 
28/05/2007) 

 Year: Để tăng 1 năm (ví dụ 28/03/2007, 28/03/2008, 28/03/2009) 

Điền một danh sách tự tạo:  

Nếu danh sách này chưa có thì ta phải tạo bằng cách 

 
Hình 10. Hộp thoại Options – OpenOffice.org Calc – Sort Lists 

- Chọn menu Tools → Option như hình sau: 

Trong khung Entries lần lượt nhập các giá trị cho danh sách, hết 
mỗi giá trị bấm Enter để xuống dòng.  

- Bấm OK 

- Để sử dụng:  

- Nhập một giá trị có trong danh sách tự tạo vào ô đầu 

- Điền tự động tới ô cuối miền như phần trên 



Hướng dẫn sử dụng OpenOffice.org Calc 
 

 18 

3.3.3 Dữ liệu kiểu công thức 

- Phải bắt đầu bởi dấu =  

- Khi cần lấy số liệu ở ô nào nháy chuột vào ô đó hoặc gõ vào địa 
chỉ ô 

Ví dụ: Để tính lương theo công thức Lương: Lương = Số ngày công 
x Lương/ ngày ta làm theo các bước sau: 

Bước 1: Gõ vào dấu = 

Bước 2: Trỏ chuột vào ô C2, bấm trái chuột (hoặc gõ C2) 

Bước 4: Gõ dấu * 

Bước 5: Trỏ chuột vào ô D2, bấm trái chuột (hoặc gõ D2). Tại ô E2 
và thanh công thức xuất hiện =C2*D2 

Bước 6: Ấn Enter 

Để tính lương cho những người còn lại, đưa con trỏ về ô E2, điền tự 
động cho tới ô E7 

- Tính tổng lương và ghi vào ô E8: 

Đưa con trỏ về ô E8 

Gõ vào dấu = trỏ chuột vào biểu tương ∑ (Sum), nháy đúp. Nếu 
người dùng bàn phím, gõ vào công thức = SUM(E2:E7) 

- Tính tỷ lệ phần trăm Lương của từng người so với Tổng lương:  

Bước 1: Đưa con trỏ về ô F2 

Bước 2: Gõ vào dấu =, dùng chuột chọn ô E2 (hoặc gõ E2), gõ 
dấu/, nháy chuột vào ô E8 (hoặc gõ E8), nhấn Enter 

Bước 3: Để tính Tỷ lệ cho những người còn lại, đưa con trỏ về 
ô/F2, sao chép công thức tính bằng cách điền tự động cho tới ô F7. 

Tại các ô F3 đến F7 xuất hiện Err:503 (Chia cho 0). Khi đưa con trỏ 
về ô F3, ta thấy trên thanh công thức ghi E3/E9, Calc đã lấy số ở ô bên 
trái (E3) chia cho số ở cách đó 6 ô (E9), ... tức là sử dụng địa chỉ tương 
đối. Để báo cho Calc lấy lần lượt các số từ E2 đến E7 chia cho số cố định 
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ở ô E8 (ô này là địa chỉ tuyệt đối), ta làm như sau: 

Đưa con trỏ ô về ô F2, nháy đúp chuột, sau đó đưa con trỏ bàn 
phím về ngay trước ký hiệu E8, bấm phím Shift + F4, dấu $ được điền 
vào trước và giữa ký hiệu đó, ấn Enter rồi copy công thức này xuống ô 
F7. 

Đánh dấu khối các ô từ F2 đến F7, chọn biểu tượng % trên thanh 
định dạng, Calc đổi ra dạng phần trăm và điền dấu % cho các số. Để lấy 
chính xác hơn, ta chọn các ô này rồi chọn biểu tượng Add Decimal 
Place, mỗi lần ấn chuột tại biểu tượng này, các con số này lại được tăng 
thêm một số thập phân. 

Sau khi tính toán ta có  

3.3.4 Công thức mảng 

Ngoài việc công thức công thức tương đối như trên, Calc còn cung 
cấp một phương tiện nhỏ gọn hơn, đó là mảng (array) 

Mảng được dùng khi ta gặp phải một lượng tính toán nhiều và phức 
tạp trên một vị trí nhỏ hẹp, hoặc dùng để thay thế các công thức cần lặp 
đi lặp lại nhiều lần, mảng giúp tiết kiệm được bộ nhớ (thay vì phải có 
100 công thức sao chép vào 100 ô, chỉ cần một công thức mảng là đủ). 

- Nhập công thức mảng (array formula):  

Bước 1: Về ô đầu tiên cần thiết cần nhập công thức mảng 

Bước 2: Khác với công thức tương đối (trong ví dụ trên là = 
C2*D2), ở đây phải lập toàn bộ dãy ô là: = C2:C7*D2:D7. 

Bước 3: Khi kết thúc phải ấn Ctrl + Shift + Enter (giữ đồng thời 2 
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phím Ctrl và Shift trong khi ấn Enter). Calc sẽ tự sinh kết quả ở các ô 
tương ứng. 

- Sửa một công thức mảng: 

Calc không cung cấp chức năng sửa một công thức mảng. 

3.4 Sửa, xóa dữ liệu 

3.4.1 Xóa 

- Đưa con trỏ ô về ô hoặc chọn miền cần thiết 

- Bấm Delete 

3.4.2 Sửa 

Làm theo một trong hai cách sau:  

- Nháy đúp chuột tại ô (hoặc nhấn phím F2), nội dung của ô xuất 
hiện tại ô đó và tại thanh công thức, đưa con trỏ về chỗ cần thiết và sửa. 
Ta nên bấm chuột tại thanh công thức và sửa tại đó, sửa xong ấn Enter để 
ghi lại, ngược lại ấn ESC để hủy bỏ mọi sửa đổi. 

- Nhập dữ liệu mới cho ô đó, sau đó nhấn phím Enter. 

3.5 Các thao tác với khối 

Khối là một miền chữ nhật trên bảng tính. 

3.5.1 Đánh dấu (chọn) khối 

- Trỏ chuột vào một góc của khối, bấm nút trái đồng thời kéo chuột 
về góc đối diện theo đường chéo. 

hoặc 

- Đưa con trỏ ô về một góc của khối, giữ phím Shift đồng thời sử 
dụng các phím mũi tên để đưa con trỏ ô về góc đối diện theo đường 
chéo. 

Các phương pháp đặc biệt. 

+ Khối là một miền liên tục: 
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Chọn khối bất kỳ: Đưa con trỏ ô về góc trái trên của khối, giữ phím 
Shift đồng thời ấn nút trái chuột tại ô ở góc phải dưới của nó. 

Chọn một cột: Ấn nút trái chuột tại tên cột đó (các chữ A, B,...), 
hoặc ấn Ctrl + dấu cách. 

Chọn một hàng: Ấn nút trái chuột tại số thứ tự của hàng đó (các số 
1, 2,...) hoặc ấn Shift + dấu cách. 

Chọn toàn bộ bảng tính: Ấn nút trái tại nút chọn toàn bộ bảng tính 
(bên trái cột A phía trên hàng 1) hoặc ấn tổ hợp phím Ctrl + A. 

+ Chọn các ô rời rạc: Đưa con trỏ tới ô đầu định chọn, giữ phím 
Ctrl và bấm nút trái chuột tại các ô định chọn tiếp theo. 

+ Khối là các miền rời rạc: Chọn vùng đầu, giữ Ctrl, bấm nút trái 
và rê chuột tại các miền khác. 

3.5.2 Copy, xóa, dán khối dùng bộ nhớ đệm. 

(Thường dùng khi miền đích và miền nguồn cách nhau hoặc để dán 
một khối vào nhiều chỗ khác nhau). 

Trước khi thực hiện các thao tác sau, ta phải chọn khối cần thiết. 

Copy: Chọn biểu tượng Copy, nhấn Ctrl + C, hoặc chọn Edit → 
Copy 

Xóa: Chọn biếu tượng Cut, hoặc nhấn Delete. 

+ Lấy khối từ bộ nhớ đệm ra dán vào bảng tính  

- Đưa con trỏ ô tới góc trái trên của miền đích 

- Chọn biểu tượng Paste, hoặc ấn Ctrl + V, hoặc chọn mục Edit → 
Paste. 

3.6 Xử lý ô, cột, hàng trong bảng tính 

3.6.1 Thay đổi kích thước cột, hàng 

Một cột / một hàng 

- Cột: Trỏ chuột vào vạch đứng ở bên phải cột tên cột sao cho xuất 
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hiện ╫, kéo và thả vạch đó tại vị trí mới. 

- Hàng: Trỏ chuột vào vạch ngang dưới số thứ tự hàng sao cho xuất 
hiện ╪, kéo và thả vạch đó tại vị trí mới. 

Nhiều cột/nhiều hàng 

- Cột:   

  - Chọn một số ô của các cột 

 -  Format → Colum → Width 

 -  Gõ vào độ rộng mới cho các cột. 

 -  Bấm OK hoặc Enter 

- Hàng: 

  - Chọn một số ô của hàng 

    - Format → Row → Height 

    - Gõ vào chiều cao mới cho các hàng 

    - Bấm OK hoặc Enter 

3.6.2 Chèn thêm cột, hàng, ô 

Chèn cột: 

- Chọn khối là tên các cột (các chữ A, B,...) tại vị trí cần chèn, cần 
thêm bao nhiêu cột ta chọn bấy nhiêu. 

- Chọn Insert → Columns. Calc sẽ chèn thêm các cột trống và đẩy 
các cột được chọn sang  phải. 

Chèn hàng: 

- Chọn khối là số thứ tự của hàng (các số 1, 2,...) tại vị trí cần chèn, 
cần thêm bao nhiêu hàng ta chọn bấy nhiêu. 

- Chọn Insert → Row. Calc sẽ chèn thêm các hàng trống và đẩy các 
hàng được chọn xuống dưới. 

Chèn ô: 

- Chọn khối là các ô tại vị trí cần chèn, cần thêm bao nhiêu ô ta 
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chọn bấy nhiêu. 

- Chọn Insert → Cells, xuất hiện hộp thoại Insert Cells 

 
Hình 11.  Hộp thoại Insert Cells 

Chọn:     Để 

- Shift Cells Right  Đẩy các ô được chọn sang phải 

- Shift Cells Down  Đẩy các ô được chọn xuống dưới 

- Ấn OK hoặc Enter  Thực hiện lệnh 

3.6.3 Xóa cột, hàng, ô 

Xóa cột: 

- Chọn khối là tên các cột (các chữ A, B, ...) tại vị trí cần xóa, cần 
xóa bao nhiêu cột ta chọn bấy nhiêu. 

- Ấn Delete. 

Xóa hàng: 

- Chọn khối là số thứ tự các hàng (các số 1, 2, ...) tại vị trí cần xóa, 
cần xóa bao nhiêu hàng ta chọn bấy nhiêu. 

- Ấn Delete. 

Xóa ô: 

- Chọn khối các ô cần xóa. 
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Hình 12. Hộp thoại Delete Contents 

- Ấn Delete hộp thoại sau xuất hiện  

Chọn các nội dung bạn cần xóa ở đây, Bấm OK  hoặc Enter để thực 
hiện xóa. 

3.6.4 Chuyển hàng thành cột và ngược lại 

Giả sử cần chuyển dữ liệu đang được xếp thành cột trong các ô 
A2:A6 thành hàng tại các ô C3:F3, ta làm như sau: 

- Chọn các ô muốn đổi chỗ hay còn gọi là miền nguồn (A2:A6) 

- Chọn biểu tượng Copy hoặc Ctrl + C 
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Hình 13. Hộp thoại Paste Special 

- Đưa con trỏ về ô đầu tiên của miếng dán (C3) 

- Chọn Edit → Past Special hộp thoại sau xuất hiện 

Trong mục Options đánh dấu chọn Transpose, bấm OK hoặc Enter 
để kết thúc. 

Chú ý: Miền nguồn và miền dán không được giao nhau (không 
được có ô chung) 

3.6.5 Ẩn/ hiện cột, hàng 

Để tiện cho thao tác, trên các bảng tính, nhất là các bảng tính lớn, 
người ta thường cho ẩn các cột (hoặc hàng) không cần thiết. Khi nào cần 
lại cho chúng hiện trở lại. Cách làm như sau: 

- Chọn các cột (hoặc các hàng) cần ẩn đi 

- Chọn Format → Columns (hoặc Row) 

- Chọn Hide. 

Tại vị trí các cột (hoặc các hàng) liền kề với chúng. Ví dụ cần cho 
các cột C, D, E hiện trở lại, ta chọn các cột đứng ngay trước và sau 
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chúng: B, F; cần cho các hàng 4, 5, 6 hiện trở lại, ta chọn các hàng ở 
ngay trên và ngay dưới chúng: 3,7. 

- Chọn Format → Columns (hoặc Row)  

- Chọn Show 

3.6.6 Cố định cột, hàng tiêu đề 

Ở các bảng tính lớn, khi cuộn xem hoặc nhập dữ liệu ở phần dưới 
thì không còn thấy tiêu đề cột của chúng ở hàng trên cùng, do đó rất dễ 
bị nhầm lẫn giữa cột nọ và cột kia. Tương tự như vậy, khi cuộn xem hoặc 
nhập dữ liệu ở bên phải thì không còn thấy các cột trái nhất (như các cột 
Họ Tên, Mặt hàng,...), rất dễ bị nhầm lần hàng nọ với hàng kia, Calc giúp 
ta cố định cột, hàng tiêu đề, cách làm như sau: 

- Đưa con trỏ về ô chuẩn để cố định. Ô này phải nằm ngay dưới 
hàng và ngay bên phải cột cần cố định. Ví dụ, cần cố định các cột A, B 
và các hàng 1, 2, ta đưa con trỏ về ô C3. 

- Chọn Window → Freeze. Tại ô chuẩn xuất hiện 2 đường kẻ dọc 
và ngang. 

- Để hủy bỏ việc cố định cột, hàng tiêu đề, chọn Window → 
Freeze. 

3.7 Định dạng dữ liệu 

3.7.1 Định dạng ký tự 

- Chọn miền dữ liệu cần định dạng, sau đó 

Dùng chuột 

- Chọn một kiểu chữ từ hộp Font 

- Chọn một cỡ chữ từ hộp Size 

- Chọn Bold để (hoặc bỏ) in đậm, chọn Italic để (hoặc bỏ) in 
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nghiêng, chọn Underline để (hoặc bỏ) gạch chân. 

- Chọn Color để đặt mầu nền. 

- Chọn Font Color để đặt mầu chữ. 

Dùng Menu (để có thể chọn nhiều mục đồng thời) 

- Chọn Format → Cells hộp thoại Format Cells xuất hiện 

- Chọn một cỡ chữ từ hộp Size. 

 
Hình 14. Hộp thoại Format Cells - Font 

- Trong Font Style chọn Italic để in nghiêng, chọn Bold để in đậm, chọn 
Bold Italic để in vừa nghiêng vừa đậm, chọn Regular để ký tự trở lại bình 
thường. 

Dùng bàn phím 

Dùng tổ hợp phím  Để 

Ctrl + B In đậm 

Ctrl + I In nghiêng 
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Ctrl + U Để gạch chân 

3.7.2 Định dạng số 

- Chọn miền dữ liệu cần định dạng, sau đó chọn các biểu tượng 
tương ứng trên thanh định dạng. 

Số Dùng biểu tượng Đổi thành 

123 Điền dấu tiền tệ  $123.00 

0.156 nhân với 100 và điền dấu %  15.6% 

12.345 lấy thêm một số thập phân  12.3450 

12.345 Giảm đi một số thập phân   12.34 

3.7.3 Canh biên (dóng hàng) 

- Chọn vùng dữ liệu cần canh biên 

Dùng biểu tượng (chỉ căn được theo chiều ngang) 

 

Ví dụ: Để có tiêu đề như dưới đây ta làm như sau: 

 

Tại ô A1 gõ: Hiệp hội các doanh nghiệp vừa&nhỏ Tp.Hà nội 

Chọn miền A1:D1 chọn biểu tượng    và căn giữa 

Tại ô A2 gõ: Công ty Cổ phần MISA 

Chọn miền A2:D2 chọn biểu tượng    và căn giữa 

Tại ô E1 gõ: Cộng hòa xã hội chủ nghĩa Việt Nam 
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Chọn miền E1:G1 chọn biểu tượng    và căn giữa 

Tại ô E2 gõ: Độc lập – tự do – hạnh phúc 

Chọn miền E2:G2 chọn biểu tượng    và căn giữa 

Dùng Menu: căn được cả theo chiều ngang và chiều dọc 

 
Hình 15. Hộp thoại Format Cells - Alignment 

- Chọn Format → Cells. Hộp thoại Format Cells xuất hiện 

- Chọn thẻ Aligment 

Các thông số dóng hàng của dữ liệu trong ô bao gồm: 

Horizontal: Định dạng theo chiều ngang 

Indent: Độ thụt vào so với lề 

Vertical: Định dạng theo chiều dọc 

Text orientation: Xoay dữ liệu theo độ trong ô Degrees. 

3.7.4 Kẻ khung 

- Chọn vùng dữ liệu cần kẻ khung. 
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- Chọn biểu tượng Border trên thanh công cụ và chọn tiếp các loại 
đường kẻ cần thiết 

hoặc 

- Chọn Format → Cells hộp thoại sau xuất hiện 

 
Hình 16. Hộp thoại Format Cells – Borders 

- Chọn thẻ Borders, chọn kiểu đường kẻ trong khung Style, mầu 
của đường kẻ trong ô Color. 

3.7.5 Tô mầu 

Chọn Format → Cells, chọn thẻ Background để tô mầu nền 

3.7.6 Định dạng tự động 

Calc có sẵn một số khuôn mẫu được sử dụng để định dạng. Các 
bước như sau: 

- Chọn vùng dữ liệu cần định dạng 

- Chọn Format → AutoFormat hộp thoại AutoFormat xuất hiện 
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Hình 17.  Hộp thoại AutoFormat 

- Chọn kiểu tạo khuôn trong danh sách Format 

- Vùng bên phải danh sách là mẫu của khuôn được minh họa trên 
một ví dụ giả định. 

3.8 Đặt tên cho ô 

Đặt tên cho ô hay nhóm ô nhằm mục đích sau: 

- Tên dễ đọc, dễ nhớ 

- Khi đã gán tên có thể tham chiếu tới ô hay nhóm ô bằng tên. 

- Việc di chuyển về một ô (hay miền) đã được đặt tên trở nên nhanh 
chóng và thuận tiện. 

Tên phải bắt đầu bởi chữ cái hoặc dấu _(nối dưới), \ (sổ chéo 
ngược), có độ dài nhiều nhất là 255 ký tự và không được chứa dấu cách. 
Để dễ đọc, các chữ cái đầu mỗi từ trong tên nên viết hoa, ví dụ 
TongLuong hay nối các từ bằng dấu _ (nối dưới), ví dụ Bang_Tra_Cuu. 
Không nên gõ tiếng việt có dấu trong tên. 

3.8.1 Đặt tên cho ô hay nhóm ô bằng tay 

Sau khi chọn ô hay nhóm ô cần đặt tên làm theo một trong hai cách 
sau: 
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Cách 1: 

    - Nháy chuột tại hộp tên trên thanh công thức, địa chỉ của ô đổi 
sang mầu xanh. 

   - Xóa địa chỉ đó đi, gõ tên vào rồi ấn Enter 

Cách 2:  

    - Chọn mục Insert → Names → Define (hoặc Ctrl + F3) 

   - Trong khung Name gõ vào tên ô hay nhóm ô.  

   - Bấm OK hoặc Enter 

3.8.2 Đặt tên theo tiêu đề của cột hay hàng (tự động) 

Các bước như sau: 

- Chọn ô hay nhóm ô cần đặt tên gồm cả các tiêu đề cột hoặc hàng. 

- Chọn Insert → Names → Create hộp thoại Create Name xuất hiện 

- Ý nghĩa các mục trong hộp Create Name như sau: 

Top Row: Lấy ô ở hàng đầu (của khối đã chọn) làm tên 

Bottom Row:  Lấy ô ở hàng cuối (của khối đã chọn) làm tên 

Left Column:  Lấy ô ở cột bên trái (của khối đã chọn) làm tên 

Right Column: Lấy ô ở cột bên phải (của khối đã chọn) làm tên 

- Bấm OK hoặc Enter. 

3.8.3 Dán tên vào công thức 

Khi nhập hay sửa công thức, thay vì điền vào địa chỉ của ô (hay 
miền) đã được đặt tên, ta 

- Nháy chuột vào hộp tên trên thanh công thức, hoặc chọn mục 
Insert → Names → Paste 

- Chọn tên cần thiết từ danh sách rồi OK 

3.8.4 Về nhanh một ô (hay miền) đã được đặt tên 

Có thể đưa con trỏ về nhanh một ô (hay miền) đã được đặt tên bằng 
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cách sau: 

Nháy chuột tại hộp tên trên thanh công thức và chọn tên cần thiết từ 
danh sách (hoặc gõ địa chỉ của ô). 

3.8.5 Xóa tên 

- Chọn Insert → Names → Define 

- Chọn tên cần xóa từ danh sách 

- Chọn Delete 

- Chọn OK 

3.8.6 Chú ý 

- Nếu muốn lấy tên của nhóm ô này để đặt cho nhóm ô khác, trước 
hết phải xóa tên nó đi. 

3.9 Ghi chú cho ô 

Có thể thêm phần ghi chú cho từng ô riêng rẽ. Những ghi chú này 
giúp ta giải thích bảng tính của mình một cách rõ ràng hơn (tại sao lại 
dùng hàm này hay đặt địa chỉ kia là tuyệt đối v.v..). 

3.9.1 Tạo ghi chú 

- Về ô cần tạo ghi chú 

- Chọn Insert → Note 

- Gõ vào lời ghi chú trong khung Text Note 

- Enter để đóng hộp thoại 

Một chấm vuông mầu đỏ ở góc phải trên của ô chỉ ra rằng ô đó đã 
được ghi chú.   

3.9.2 Xem các ghi chú 

- Nếu cần xem ghi chú của một ô: chỉ việc rà chuột vào ô đó, một 
khung với nội dung ghi chú xuất hiện. Để tắt khung này ta phải rà chuột 
sang ô khác. 
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3.10 Bảo vệ ô 

Trong một số trường hợp, để giới hạn quyền sử dụng của người 
khác, ví dụ: không cho họ sửa đổi một số ô này hay xem công thức ở một 
số ô khác v.v.. hãy sử dụng tính năng bảo vệ và che dấu ô. Cách làm như 
sau: 

- Chọn ô hay nhóm ô cần bảo vệ. 

- Chọn mục Format → Cells chọn thẻ Cell Protection 

- Trong hộp thoại đánh dấu chọn vào 

Hide all: Để che dấu không cho xem tất cả 

Protected: Để bảo vệ ô 

Hide formula: Để che dấu không cho xem công thức 

Hide when printing: Để che dấu không cho xem khi in ra. 

Sau đó cần phải thiết lập bảo vệ bảng tính thì thiết lập trên mới có 
tác dụng.
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Chương 04 

HÀM TRONG CALC 

Hàm (Function) được xem như là các công thức định sẵn nhằm 
thực hiện các tính toán chuyên biệt. Trên ô thực hiện hàm sẽ cho một giá 
trị hoặc một thông báo lỗi. Calc có trên 300 hàm và được phân loại thành 
từng nhóm. 

4.1 Quy tắc sử dụng hàm 

- Các hàm có dạng tổng quát: TênHàm(Các tham biến). Ví dụ: 

Hàm  cho kết quả 

TODAY() là ngày hiện tại trong máy 27/03/2007 
(hàm không cần tham biến) 

LEN(“MISA”) độ dài của chuỗi là 4 (hàm 1 tham biến) 

AVERAGE(A; B5; C6) là trung bình cộng các số trong các ô 
A1,B5,C6 (hàm nhiều tham biến) 

- Tên hàm có thể viết thường hay viết hoa hoặc vừa viết thường vừa 
hoa đều được. 

- Các biến có thể có hoặc không nhưng phải đặt trong hai dấu ( ) và 
cách nhau bởi dấu phẩy, dấu chấm phẩy hoặc một dấu ngăn cách nào 
khác tùy theo cách đặt các thông số quốc tế. Trong một hàm có thể chứa 
nhiều nhất 30 tham biến nhưng không được vượt quá 255 ký tự. 

- Trong hàm không được có dấu cách. 

- Hàm phải được bắt đầu bởi dấu = hoặc dấu của một phép tính. 
Trường hợp dùng một hàm để làm tham biến cho một hàm khác (hàm 
lồng nhau, nhiều nhất là 7 mức) không cần viết dấu = trước tên hàm đó. 
Ví dụ: các ô A1, B1 chứa số đo các cạnh của tam giác vuông, khi đó 
công thức = SQRT(SUM(A1^2;B1^2)) gõ tại ô C1 cho số đo cạnh 
huyền. 

Ở đây SQRT là hàm khai căn bậc hai, SUM là hàm tính tổng (bình 
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phương của 2 cạnh góc vuông), ta thấy trước hàm này không có dấu = vì 
nó được dùng làm tham biến (đối số) cho hàm SQRT. 

4.2 Nhập hàm vào bảng tính 

Có 3 cách nhập hàm vào bảng tính: 

- Gõ vào từ bàn phím 

- Dùng biểu tượng  (Function Wizard) 

- Dùng Menu 

Để nhập hàm ta đưa con trỏ về ô cần nhập rồi chọn một trong 3 
cách sau: 

4.2.1 Gõ vào từ bàn phím  

- Gõ dấu = 

- Gõ vào tên hàm, dấu (; các tham biến theo đúng dạng thức quy 
định, dấu) 

4.2.2 Dùng biểu tượng Function Winzard.  

Bước 1: Chọn biểu tượng trên thanh công thức. Xuất hiện hộp 
thoại Function Winzard như sau: 

 
Hình 18. Hộp thoại Function Wizard 
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Ý nghĩa của các nhóm hàm trong khung Category như sau: 

 All  : Tất cả các hàm 

 Financial : Hàm tài chính 

 Date&Time : Hàm ngày và giờ 

 Statistical : Hàm thống kê 

 ....... 

Bước 2: Chọn nhóm hàm nào trong khung Category. Khi di chuyển 
thanh sáng đến nhóm nào, Calc sẽ liệt kê các hàm của nhóm đó theo thứ 
tự chữ cái trong khung Function. 

Bước 3: Bấm đúp chuột chọn hàm trong khung Function hộp thoại 
xuất hiện khung các tham biến cần nhập. 

 
Hình 19. Hộp thoại Function Wizard đã chọn hàm 

Điền các tham biến của hàm bằng cách ấn nút chuột vào khung cần 
thiết, sau đó nhập từ bàn phím hoặc rê chuột trên miền dữ liệu. Trường 
hợp cần gọi hàm khác chọn nút  bên trái của khung. 
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Bước 4: Chọn OK, Calc tắt hộp thoại và ghi kết quả của hàm vào ô. 

4.2.3 Dùng Menu 

- Chọn mục Insert → Function. Xuất hiện hộp thoại Function 
Winzard 

- Các bước còn lại giống như khi nhập công thức bằng biểu tượng. 

4.3 Các hàm trong Calc 

4.3.1 Hàm ngày tháng 

Một số lưu ý khi sử dụng ngày tháng và thời gian trong Calc:  

Calc hỗ trợ tính toán ngày tháng cho Windows và Macintosh. 
Windows dùng hệ ngày bắt đầu từ 1900. Macitosh dùng hệ ngày bắt đầu 
từ 1904. Tài liệu này được diễn giải theo hệ ngày 1900 dành cho 
Windows.  

Hệ thống ngày giờ Calc phụ thuộc vào thiết lập trong Regional 
Options của Control Panel. Mặc định là hệ thống của Mỹ 
"Tháng/Ngày/Năm" (M/d/yyyy). Bạn có thể sửa lại thành hệ thống ngày 
của VN "Ngày/Tháng/Năm" (dd/MM/yyyy).   

Khi bạn nhập một giá trị ngày tháng không hợp lệ nó sẽ trở thành 
một chuỗi văn bản. Công thức tham chiếu tới giá trị đó sẽ trả về lỗi.   

Tên hàm Công dụng 

DATE Trả về chuỗi số tuần tự của ngày tháng. 

DATEVALUE Trả về chuỗi số đại diện cho ngày từ chuỗi văn 
bản đại diện cho ngày tháng.  

DAY Trả về thứ tự của ngày trong tháng từ một giá trị 
kiểu ngày tháng.   

DAYS360 Tính số ngày giữa 2 mốc ngày tháng dựa trên cơ 
sở một năm có 360 ngày.  

EDATE  Trả về mốc thời gian xảy ra trước hoặc sau mốc 
chỉ định  
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EOMONTH Trả về ngày cuối cùng của tháng xảy ra trước 
hoặc sau mốc chỉ định   

HOUR Trả về giờ của một giá trị kiểu thời gian.   

MINUTE Trả vế phút của một giá trị kiểu thời gian  

MONTH Trả về số tháng của một giá trị kiểu ngày tháng.  

NETWORKDAYS Trả về số ngày làm việc trong mốc thời gian đưa 
ra sau khi trừ đi ngày nghĩ và ngày lễ.  

NOW Trả về ngày giờ hiện tại trong hệ thống của bạn. 

SECOND Trả về số giây của một giá trị thời gian. 

TIME Trả về một giá trị thời gian từ chuỗi văn bản 

TIMEVALUE  Trả về một giá trị thời gian từ một chuỗi kiểu
thời gian. 

TODAY Trả về ngày hiện tại trong hệ thống của bạn.   

WEEKDAY Trả về số thứ tự của ngày trong tuần từ giá trị 
ngày tháng. 

WEEKNUM Trả về số thứ tự của tuần trong năm từ giá trị 
ngày tháng. 

WORKDAY Trả về ngày làm việc xảy ra trước hoặc sau mốc 
thời gian đưa ra.   

YEAR Trả về số năm của một giá trị ngày tháng. 

YEARFRAC Trả về tỉ lệ của một khoảng thời gian so với
năm. 

4.3.2 Hàm ký tự 

Bao gồm các hàm xử lý chuỗi văn bản như trích lọc, tìm kiếm, thay 
thế, chuyển đổi chuỗi văn bản.  

Tên hàm Công dụng 

CHAR Chuyển số thành ký tự 
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CLEAN Xóa ký tự không phù hợp  

CODE Trả về mã số của ký tự đầu tiên  

CONCATENATE Nối nhiều chuỗi thành một chuỗi 

DOLLAR  Chuyển định dạng số thành tiền tệ 

EXACT So sánh hai chuỗi văn bản  

FIND Tìm kiếm một chuỗi trong chuỗi khác 

FIXED Chuyển một số sang định dạng văn bản 

LEFT Trích bên trái một chuỗi  

LEN Tính độ dài một chuỗi 

LOWER Chuyển thành chữ thường. 

PROPER Chuyển ký tự đầu mỗi từ thành chữ hoa 

MID Trích chuỗi con từ một chuỗi  

REPLACE Thay thế một phần của chuỗi.  

RIGHT Trích bên phải một chuỗi  

REPT Lặp lại một chuỗi 

SUBSTITUTE Thay thế một chuỗi xác định   

SEARCH Tìm kiếm một chuỗi   

TEXT Chuyển một số sang text.   

T Kiểm tra dữ liệu kiểu text   

TRIM Xóa những ký tự trắng bên trong chuỗi.  

UPPER Chuyển ký tự thường thành hoa. 

VALUE Chuyển một chuỗi thành số. 

4.3.3 Hàm toán học 

Bao gồm các hàm về toán học và lượng giác giúp bạn có thể giải 
một bài toán đại số, giải tích, hoặc lượng giác từ tiểu học đến đại học...  

Lưu ý đến quy cách hiển thị số của VN và của US. Để luôn nhập 
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đúp một giá trị kiểu số bạn hãy sử dụng bàn phím số.   

Tên hàm Công dụng 

ABS  Tính trị tuyệt đối của một số 

ACOS Tính nghịch đảo cosin  

ACOSH Tính nghịch đảo cosin hyperbol 

ASIN  Tính nghịch đảo sin  

ASINH Tính nghịch đảo sin hyperbol    

ATAN Tính nghịch đảo tang    

ATAN2 Tính nghịch đảo tang với tọa độ 

ATANH Tính nghịch đảo tang hyperbol 

CEILING Là tròn đến bội số gần nhất  

COMBIN Tính tổ hợp từ số phần tử chọn 

COS Tính cosin của một góc 

COSH Tính cosin hyperbol  

DEGREES Đổi radians sang độ 

EVEN Làm tròn một số đến số nguyên chẵn gần nhất. 

EXP Tính lũy thừa cơ số e    

FACT  Tính giai thừa của một số     

FACTDOUBLE Tính lũy thừa cấp 2 

FLOOR Làm tròn xuống đến bội số gần nhất do bạn chỉ. 

GCD Tìm ước số chung lớn nhất   

INT Làm tròn xuống số nguyên gần nhất 

LCM Tìm bội số chung nhỏ nhất 

LN Tính logarit cơ số tự nhiên của một số     

LOG Tính logarit 

LOG10 Tính logarit cơ số 10 
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MDETERM Tính định thức của ma trận 

MINVERSE Tìm ma trận nghịch đảo 

MMULT Tính tích 2 ma trận 

MOD Lấy phần dư của phép chia  

MROUND Làm tròn một số đến bội số của số khác.  

MULTINOMIAL Tỷ lệ giai thừa tổng với tích các giai thừa của các
số. 

ODD Làm tròn đến một số nguyên lẽ gần nhất. 

PI Trả về giá trị pi 

POWER Tính lũy thừa của một số  

PRODUCT  Tính tích các số 

QUOTIENT Lấy phần nguyên của phép chia  

RADIANS Đổi độ sang radians. 

RAND Trả về một số ngẫu nhiên trong khoảng 0 và 1 

RANDBETWEENTrả về một số ngẫu nhiên trong khoảng do bạn 
chỉ định 

ROMAN Chuyển một số sang số La Mã 

ROUND Làm tròn một số 

ROUNDDOWN Làm tròn một số hướng xuống zero 

ROUNDUP Làm tròn một số hướng ra xa zero. 

SERIESSUM Tính tổng lũy thừa...  

SIGN Trả về dấu của một số 

SIN Tính sin của một góc 

SINH Tính sin hyperbol của một số 

SQRT  Tính căn bậc 2 của một số 

SQRTPI Tính căn bậc 2 của một số nhân với pi 
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SUBTOTAL Tính tổng phụ  

SUM Tính tổng của các số 

SUMPRODUCT Tính tổng các tích các phần tử tương ứng trong 
các mảng giá trị 

SUMX2MY2 Tính tổng của hiệu bình phương các phần tử 
tương ứng của 2 mảng giá trị    

SUMX2PY2 Tính tổng của tổng bình phương các phần tử 
tương ứng của 2 mảng giá trị         

SUMXMY2 Tính tổng của bình phương hiệu các phần tử 
tương ứng của 2 mảng giá trị.    

TAN Tính tang của một góc 

TANH Tính tang hyperbol của một số 

TRUNC Cắt bớt phần thập phân của số  

4.3.4 Hàm logic 

Hàm logic luôn trả về một trong 2 giá trị TRUE (đúng) hoặc 
FALSE (sai). 

Kết quả của hàm logic dùng làm đối số trong các hàm có sử dụng 
điều kiện như IF, SUMIF, COUNTIF, .... 

Tên hàm Công dụng 

AND Và 

OR Hoặc 

NOT Phủ định 

FALSE Sai 

TRUE Đúng  

IF Trả về kết quả với điều kiện 

4.3.5 Hàm thống kê 

Bao gồm các hàm số giúp bạn giải quyết các bài toán thống kê từ 
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đơn giản đến phức tạp.    

Tên hàm Công dụng 

AVEDEV Tính bình quân độ phân cực  

AVERAGE Tính trung bình cộng các số. 

AVERAGEA Tính trung bình cộng các giá trị   

COUNT Đếm ô dữ liệu chứa số 

COUNTA Đếm số ô chứa dữ liệu  

MAX Tìm số lớn nhất  

MAXA Tìm giá trị lớn nhất  

MIN Tìm số nhỏ nhất 

MINA Tìm giá trị nhỏ nhất 

RANK Tìm vị thứ của một số trong dãy số.  

4.3.6 Hàm tìm kiếm và tham chiếu 

Bao gồm các hàm tìm kiếm và tham chiếu rất hữu ích khi bạn làm 
việc với CSDL lớn trong Calc như kế toán, tính lương, thuế...   

Tên hàm Công dụng 

ADDRESS Tạo địa chỉ dạng chuỗi ký tự. 

AREAS Đếm số vùng tham chiếu  

CHOOSE Trả về giá trị trong mảng giá trị tại vị trí được chỉ 
định. 

COLUMN Trả về số thứ tự cột của ô đầu tiên trong vùng 
tham chiếu.                

COLUMNS  Trả về số cột của vùng tham chiếu. 

HLOOKUP Dò tìm một giá trị trên hàng đầu tiên và trả về ... 

HYPERLINK  Tạo một siêu liên kết   
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INDEX Trả về một giá trị trong bảng dữ liệu tương ứng 
với chỉ mục của nó.                

INDIRECT Trả về giá trị của một tham chiếu  

LOOKUP Dò tìm một giá trị 

MATCH Trả về vị trí của một giá trị trong bảng dữ liệu  

OFFSET Trả về một vùng tham chiếu từ một vùng xuất 
phát. 

ROW Trả về số thứ tự dòng của ô đầu tiên trong dãy ô.   

ROWS Trả về số dòng của dãy tham chiếu. 

TRANSPOSE Hoán vị hướng một vùng một giá trị.  

VLOOKUP Dò tìm một giá trị trên cột đầu tiên và trả về.... 
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Chương 05 

ĐỒ THỊ 

Khả năng biểu diễn số liệu bằng đồ thị của Calc rất phong phú. Các 
biểu đồ được cài đặt trên bảng tính tăng thêm sức hấp dẫn và thuyết phục 
của số liệu. 

5.1 Các bước tạo đồ thị mới 

Bước 1: Chọn miền dữ liệu cần đưa vào vẽ đồ thị, ví dụ A2:E6, chú 
ý chọn cả hàng tiêu đề 2003, 2004... và cột tên các bảng tính để làm nhãn 
cho đồ thị. 

Bước 2: Chọn biểu tượng    (Insert Chart), con trỏ chuột trở thành 
dấu cộng. 

Bước 3: Xác định miền hình chữ nhật tại vùng trống của bảng tính 
để đưa đồ thị vào bằng cách trỏ chuột vào đỉnh trái trên của nó, ấn và giữ  
nút trái đồng thời kéo chuột về đỉnh phải dưới, thả nút chuột, xuất hiện 
hộp thoại sau 
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Hình 20. Hộp thoại AutoFormat Chart 

Bước 4: Nếu cần, sửa lại địa chỉ của miền dữ liệu đưa vào vẽ đồ thị 
trong khung Range bằng cách gõ trực tiếp hoặc dùng chuột chọn miền dữ 
liệu cần thiết. Chọn Next  

 
Hình 21. Hộp thoại cho phép chọn kiểu đồ thị 

Bước 5: Chọn kiểu đồ thị bạn muốn, bấm Next 



Hướng dẫn sử dụng OpenOffice.org Calc 
 

 48 

 
Hình 22. Hộp thoại cho phép chọn dạng đồ thị 

Bước 6: Chọn một dạng đồ thị, nếu dùng bàn phím, gõ số thứ tự 
của dạng cần chọn, bấm Next 

 
Hình 23. Hộp thoại cho phép gõ tên biểu đồ 

Bấm Create để kết thúc. 

5.2 Thiết lập lại đồ thị 

Bước 1: Chọn đồ thị bằng cách trỏ chuột vào trong lòng nó và bấm 
nút trái. Xuất hiện khung bao quanh đồ thị với các chấm vuông ở các góc 
và giữa các cạnh. 
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Bước 2: Chọn biểu tượng Insert Chart, Calc lần lượt đưa ta trở lại 
các bước đã nêu trên. 

5.3 Chỉnh  sửa đồ thị 

5.3.1 Chỉnh sửa các đối tượng 

Bước 1: Trỏ chuột vào trong lòng đồ thị nháy đúp, xuất hiện khung 
chữ nhật có cạnh là các sọc chéo với chấm vuông hoặc một cửa sổ riêng. 

Bước 2: Để sửa kiểu đồ thị chọn Format → Chart Type 

Để sửa các đối tượng khác, nháy đúp tại đối tượng cần thiết (ví dụ 
tiêu đề chung của đồ thị), xuất hiện khung chữ nhật với chấm vuông tại 
các góc và giữa các cạnh. Chọn Format, chọn mục cần thiết để chỉnh sửa. 

5.3.2 Bổ sung/bỏ đường kẻ lưới 

- Bấm chuột vào trong lòng đồ thị. 

- Chọn Insert → Grids. Đánh dấu chọn vào các ô cần thiết để bổ 
sung các đường kẻ lưới, bỏ dấu chọn để hủy bỏ các đường này. 

5.3.3 Bổ sung thêm đường biểu diễn 

Ví dụ: Để bổ sung thêm đường biểu diễn số liệu của năm 2007 vào 
đồ thị: 

- Chọn miền dữ liệu cần bổ sung 

- Kéo thả miền này vào đồ thị 
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Chương 06 

QUẢN TRỊ DỮ LIỆU 

6.1 Khái niệm cơ bản 

Cơ sở dữ liệu (CSDL) là tập hợp các dữ liệu được sắp xếp trên một 
vùng chữ nhật (gồm ít nhất 2 hàng) của bảng tính theo quy định sau: 

- Hàng đầu tiên ghi các tiêu đề của dữ liệu, mỗi tiêu đề trên một cột. 
Các tiêu đề này được gọi là trường (field) 

- Từ hàng thứ hai trở đi chứa dữ liệu, mỗi hàng là một bản ghi 
(record) 

Chú ý: 

 + Tên các trường phải là dạng ký tự, không được dùng số, công 
thức, tọa độ ô... ). Nên đặt tên trường ngắn gọn, không trùng lặp. 

 + Không nên có miền rỗng trong CSDL. 

6.2 Sắp xếp dữ liệu 

- Nếu định sắp xếp cho toàn bộ CSDL: về ô bất kỳ của nó. Nếu chỉ 
định sắp xếp cho một số bản ghi: chọn miền dữ liệu cần đưa vào sắp xếp.  

 
Hình 24. Hộp thoại Sort – Sort Criteria 
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- Mở menu Data → Sort, xuất hiện hộp thoại Sort 

- Calc cung cấp 3 điều kiện để sắp xếp. Chọn các trường cần sắp 
xếp. 

Sau đây là ý nghĩa các mục: 

Sort by Cột ưu tiên nhất trong khóa sắp xếp. 

Then by Cột ưu tiên thứ hai và thứ ba trong khóa sắp xếp 

Ascending Sắp xếp tăng dần 

Desending Sắp xếp giảm dần 

Thẻ Option  

Case Sensitive Phân biệt chữ hoa với chữ thường 

Top to bottom (sort rows) Sắp xếp các dòng trong CSDL 

Left to right (sort columns) Sắp xếp các cột trong CSDL. 

- Chọn OK để bắt đầu sắp xếp. 

Hình trên là hộp thoại Sort với các thông số để danh sách được xếp 
theo vần A, B, C của Tên, những bản ghi trùng tên thì xếp người có ĐTB 
cao lên trên, những bản ghi trùng ĐTB thì xếp người có điểm Tin cao lên 
trên. 

6.3 Lọc dữ liệu 

6.3.1 Các yếu tố cơ bản 

Để thực hiện lọc dữ liệu, phải xác định các yếu tố cơ bản sau trên 
bảng tính:  

- Miền dữ liệu (Database): chứa toàn bộ dữ liệu cần xử lý, kể cả 
hàng tiêu đề. 

- Miền tiêu chuẩn (Criteria): là miền bất kỳ trên bảng tính ngoài 
vùng CSDL, chứa các tiêu chuẩn (điều kiện mà các bản ghi phải thỏa 
mãn). Miền tiêu chuẩn gồm tối thiểu 2 hàng: hàng đầu chứa tiêu đề của 
miền tiêu chẩn. Các tiêu đề này hoặc là tên trường hoặc là tên bất kỳ phụ 
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thuộc vào phương pháp thiết lập tiêu chuẩn trực tiếp hay gián tiếp. Từ 
hàng thứ hai trở đi là tiêu chuẩn của CSDL. 

Miền tiêu chuẩn so sánh trực tiếp: cho phép đưa vào các tiêu chuẩn 
để so sánh dữ liệu trong một trường với một giá trị nào đó. Tiêu chuẩn so 
sánh trực tiếp được tạo ra theo nguyên tắc sau:  

- Hàng đầu ghi tiêu đề chuẩn, lấy tên trường làm tiêu đề. 

- Hàng thứ hai trở đi để ghi các tiêu chuẩn so sánh, trước các giá trị 
đó có thể thêm các toán tử so sánh như >, >=, <, <=. Các tiêu chuẩn trên 
cùng hàng (thường gọi là điều kiện và – and) được thực hiện đồng thời. 
Các tiêu chuẩn trên các hàng khác nhau (thường được gọi là điều kiện 
hoặc là – or) được thực hiện không đồng thời. 

Miền tiêu chuẩn so sánh gián tiếp: hay còn gọi là tiêu chuẩn công 
thức: cho phép đưa vào các tiêu chuẩn để so sánh dữ liệu  hoặc một phần 
dữ liệu trong một trường với một giá trị nào đó. Tiêu chuẩn so sánh gián 
tiếp được tạo ra theo nguyên tắc sau: 

- Hàng đầu ghi tiêu đề cho các tiêu chuẩn. Tiêu đề này có thể đặt 
bất kỳ nhưng không được trùng với tên trường nào. 

- Từ hàng thứ hai trở đi ghi các tiêu chuẩn so sánh, mỗi tiêu chuẩn 
là một công thức. Công thức này phải chứa địa chỉ của bản ghi đầu tiên. 
Kết quả thực hiện công thức này là một giá trị Logic: TRUE (đúng) hoặc 
FALSE (Sai) 

Miền đích (Copy to): miền trống trên bảng tính, dùng để chứa các 
bản ghi đạt tiêu chuẩn. 

6.3.2 Lọc tự động (AutoFilter) 

- Chọn miền dữ liệu định lọc (kể cả hàng tiêu đề). 

- Chọn menu Data → Filter → AutoFilter, Calc tự động chèn 
những mũi tên vào bên phải của các tên trường. 

- Chọn mũi tên tại cột chứa dữ liệu dùng làm tiêu chuẩn để lọc (Ví 
dụ tại cột Chức Vụ) 
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- Chọn một trong các mục tại menu để lọc tự động theo mục đích 
của mình. 

Phần còn lại là danh sách giá trị của các bản ghi trong CSDL tại cột 
đó. Khi cần lọc các bản ghi theo một giá trị cụ thể nào đó chỉ cần chọn 
giá trị đó trong Menu (ví dụ chọn Giám Đốc). 

Hủy lọc dữ liệu: 

- Hủy lọc trong 1 cột: Bấm chuột tại mũi tên của cột đó, chọn [All] 

- Hủy lọc toàn bộ: Data → Filter → AutoFilter để xóa dấu chọn. 

6.3.3 Lọc nâng cao (Advanced Filter) 

Advanced Filter dùng để tìm các bản ghi thỏa mãn các điều kiện 
phức tạp hơn. Chức năng lọc nâng cao này ứng với các tiêu chuẩn so 
sánh gián tiếp, bắt buộc phải dùng miền tiêu chuẩn. Các bước như sau: 

- Chọn miền tiêu chuẩn 

- Chọn miền dữ liệu định lọc 

 
Hình 25. Hộp thoại Advanced Filter 

- Data → Filter → Advanced Filter, hộp thoại Advanced Filter xuất 
hiện 

Chọn các trường cần lọc rồi OK. 
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6.4 Tổng kết theo nhóm 

6.4.1 Tổng kết theo một loại nhóm (SubTotal): 

Chức năng này cho phép tạo các dòng tổng kết trong một CSDL. 
SubTotal sẽ chèn tại các vị trí cần thiết các tính toán thống kê theo yêu 
cầu của người sử dụng. Các bước thực hiện như sau: 

Bước 1: Sắp xếp dữ liệu theo trường cần tạo SubTotal 

Bước 2: Chọn Data → SubTotal xuất hiện hộp thoại SubTotal 

Trong đó 

 
Hình 26. Hộp thoại Subtotals 

- Chọn trường cần tính toán tại Calculate subtotals for. 

- Chọn hàm để tính toán tổng kết dữ liệu. Hàm ngầm định là SUM.  

6.4.2 Tổng kết theo nhiều loại nhóm  

Chức năng này của Calc cho phép tự động hóa quá trình tổng kết 
theo nhiều nhóm, phân tích và đánh giá số liệu mà sau đây chúng tôi gọi 
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là: Bảng tổng hợp. 

Bảng tổng hợp được chia làm 4 vùng: 

- Page Field: Toàn bộ dữ liệu được tổng kết theo từng nhóm của 
trường này. Page Field luôn nằm ở phía trên của bảng tổng hợp. 

- Row Field: Mỗi nhóm dữ liệu của trường này được tổng kết trên 
một dòng, vì vậy được gọi là “Row”. Nếu số Row Field nhiều hơn 1, 
bảng tổng hợp sẽ tổng kết các trường này theo kiểu lồng nhau theo thứ tự 
từ trên xuống dưới. 

- Column Field: Mỗi nhóm dữ liệu của trường này được tổng kết 
trên một cột, vì vậy được gọi là “Column”. Nếu số nhóm này nhiều hơn 
1, bảng tổng hợp sẽ tổng kết các nhóm này theo thứ tự từ trái sang phải. 

- Data Field: Vùng chính của bảng tổng hợp ghi kết quả của một 
phép toán. 

Tạo mới một bảng tổng hợp 

- Chọn miền dữ liệu kể cả tiêu đề của các cột 

- Chọn Data → DataPilot hộp thoại DataPilot xuất hiện 

 
Hình 27. Hộp thoại DataPilot 



Hướng dẫn sử dụng OpenOffice.org Calc 
 

 56 

- Chọn các trường để đưa vào các vùng của bảng bằng cách kéo và 
thả tên trường ở bên phải hộp thoại tới các vùng được ấn định trong 
bảng. Bấm OK để kết thúc. 

Điều chỉnh bảng tổng hợp 

- Thay đổi vị trí các trường: Trong bảng tổng hợp kéo và thả tên 
trường tại vị trí mong muốn.  

- Bổ sung các trường: 

 + Chọn ô bất kỳ của bảng tổng hợp 

 + Chọn mục Data → DataPilot 

 + Thực hiện lại các bước như khi tạo mới bảng tổng hợp để  bổ 
sung trường vào các vị trí mong muốn. 

- Xóa trường: Trong bảng tổng hợp kéo tên trường cần xóa ra khỏi 
bảng. 

- Sửa tên trường: Đưa con trỏ ô về trường cần thiết trong bảng tổng 
hợp và tiến hành sửa tên như sửa dữ liệu của bảng tính. 

Tự động điều chỉnh bảng tổng hợp khi dữ liệu gốc thay đổi 

Sau khi sửa số liệu của CSDL 

- Chọn ô bất kỳ của bảng tổng hợp 

- Chọn Data → Data Pilot → Refresh 
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Chương 07 

TRÌNH BÀY TRANG VÀ IN 

7.1 Chọn cỡ giấy, hướng in, đặt lề 

- Chọn Format → Page, xuất hiện hộp thoại Page Styles, chọn thẻ 
Page 
 

 
Hình 28. Hộp thoại Page Style - Page 

- Chọn cỡ giấy trong khung Paper Format 

- Chọn Landscape để in giấy ngang, Portait để in dọc 

- Trong phần Margins chọn khoảng cách cho 

 Top  Lề trên 

 Bottom Lề dưới 

 Left  Lề trái 

 Right  Lề phải 



Hướng dẫn sử dụng OpenOffice.org Calc 
 

 58 

- Đặt lại khoảng cách các lề cho phù hợp, cần chú ý rằng các 
khoảng cách này được tính bằng cm hoặc inch 

- Bấm OK 

7.2 Tạo tiêu đề đầu/cuối trang 

Chọn Edit → Headers & Footers 

- Chọn Headers hoặc Footers, xuất hiện danh sách các mẫu, ý nghĩa 
của chúng như sau: 

(none) Để trống phần tiêu đề đầu/cuối trang 

Page 1 In chữ Page kèm theo số trang 

Page 1 of In chữ Page kèm theo số trang của tổng số trang 

Một số mẫu (sample) xuất hiện cho ta thấy kết quả của việc chọn. 
Bạn cũng có thể gõ vào tiêu đề đầu/cuối theo ý mình. 

- Chọn OK 

7.3 Lặp lại tiêu đề của bảng tính khi sang trang 

Ở các bảng tính lớn, mỗi khi sang trang, để tránh phải gõ lại các 
tiêu đề, ta làm như sau:  

Chọn Format → Print Ranges → Edit hộp thoại sau xuất hiện 

 
Hình 29. Hộp thoại Edit Print Ranges 

- Nếu cần lặp lại các hàng tiêu đề, trong khung Rows to repeat điền 
số thứ tự của chúng. Như hình vẽ, hàng thứ 2 của bảng tính được lặp lại, 
ta điền vào $2 (bằng cách gõ trực tiếp hoặc dùng chuột chọn 1 ô bất kỳ 
nào của hàng đó). 
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- Nếu cần lặp lại các cột bên trái  bảng tính trong khung Columns to 
repeat điền thứ tự của chúng bằng cách gõ trực tiếp hoặc dùng chuột 
chọn 2 ô bất kỳ nào trên cùng hàng của 2 cột đó. Chọn OK hoặc ấn 
Enter. 

Ta chỉ thấy tiêu đề lặp lại khi chọn biểu tượng Print Preview hoặc 
in ra giấy. 

7.4 In 

Trước khi in nên:  

- Chọn mục File → Print Preview (hoặc biểu tượng Print Preview) 
để xem bố cục bảng tính. 

- Kiểm tra xem máy in đã sẵn sàng chưa. 

Để in toàn bộ bảng tính, chọn biểu tượng Print trên thanh công cụ 

Để in từng phần bảng tính: 

 
Hình 30. Hộp thoại Print 

- Chọn mục File → Print xuất hiện hộp thoại sau 

Selection  In một khối đã được chọn trước đó. 



Hướng dẫn sử dụng OpenOffice.org Calc 
 

 60 

Page In một dãy các trang: điền vào số thứ tự của trang 
đầu và trang cuối cần in, cách nhau bằng dấu - 

Chọn OK hoặc ấn Enter để in 
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 BÀI TẬP 

Câu 1: Nhập liệu, tính toán  và lưu file với  cau1.ods 

BẢNG DỰ TRÙ VẬT TƯ 

STT Tên Vật Tư ĐVT 
Đơn giá 

(đồng VN) 
Số Lượng 

Thành Tiền 

(đồng VN) 

1 Xi măng P400 Bao           5000 1845  

2 Cát M3        30000 16  

3 Gạch thẻ 1000 viên      400000 12  

4 Sắt 10 Kg          5200 345  

5 Gạch men M2 52000 35  

6 Sắt 20 Kg 6200 20  

7 Gạch granit M2 132000 12  

8 Gạch viền Viên 2000 2520  

9 Bột trét tường Kg 1000 150  

10 Sơn nước Kg 12000 150  

11 Sơn dầu Kg 25000 35  

12 Gạch trang trí viên 2500 100  

     

    Tổng cộng  

Yêu cầu tính toán:  Thành Tiền = Đơn Giá * Số Lượng. 

   Tổng cộng = Tổng của cột Thành Tiền 
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Câu 2:  Nhập liệu, tính toán  và lưu file với  cau2.ods. 

LẬP CÔNG THỨC 

STT A B A+B A*B A/B A+B*2 (A+B)*2 A+B +A*B 

1 12 4       

2 16 49       

3 3.2 26.2       

4 12.5 29.7       

5 27 156       

6 421 12       

7 45 97.3       

8 34.1 13.3       

9 16.4 12       

10 15 561       

11 24.5 19       

12 38.1 28.3       
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Câu 3: Nhập liệu và tính toán,  lưu file với tên cau3.ods 

TÌNH HÌNH THỰC HIỆN KẾ HOẠCH Năm 2006 

      Đơn vị tính: 1,000,000 VNĐ 

ST

T 
Tên đơn vị 

Kế 

hoạch 

Quý 

I 

Quý 

II 

Quý 

III 

Quý 

IV 

Cả 

năm 
Tỷ lệ Đánh giá 

1 XN Cơ khí 900 145 411 267 280  12 Đạại A 

2 XN Dệt 1,200 425 341 318 320 1,04   

3 XN May 1,400 390 438 346 311  1 ạt loại B 

4 XN Giày Da 870 167 179 214 235 795 .38% ông đạt 

5 XN Đông Lạnh 2,100 456 541 534 532  98 hông đạt 

6 XN Thuốc lá 756 232 224 245 257    

7 XN Thuỷ sản 340 120 156 137 198    

8 XN Chăn nuôi 120 35 32 27 30    

Yêu cầu tính toán: 

CẢ NĂM = Cộng của 4 quý 

TỶ LỆ  = CẢ NĂM / KẾ HOẠCH (Định dạng % và lấy hai số lẻ) 

ĐÁNH GIÁ :  Nếu TỶ LỆ  < 100%  → Không đạt 

Nếu TỶ LỆ  >=100% → Đạt  

Xếp lại bảng tính theo thứ tự giảm dần của cột CẢ NĂM. 
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Câu 4: Tính toán bài tập này và lưu file với tên  cau4.ods 

BẢNG KÊ HÀNG BÁN THÁNG 3/2007 

STT TÊN HÀNG SỐ LƯỢNG ĐƠN GIÁ THUẾ PHÍ VC THÀNH TIỀN 

1 Máy lạnh 12 540       

2 Tivi 45 320       

3 Xe Dream II 15 2800       

4 Máy giặt 20 300       

5 Đầu Video 5 120       

6 Đầu DVD 60 230       

7 Computer 13 460    

8 Printer 15 120     

9 Scanner 10 250    

10 Camera 8 1230    

11 Maxtor HDD 80 79    

  TỔNG CỘNG    

Giải thích:  PHÍ VC: phí vận chuyển. 

Tính toán: 

THUẾ = SỐ LƯỢNG * ĐƠN GIÁ * 10% 

PHÍ VC = ĐƠN GIÁ * SỐ LƯỢNG * TỈ LỆ VC 

TỈ LỆ VC =  6%  NẾU SỐ LƯỢNG < 30. 

TỈ LỆ VC =  4%  NẾU SỐ LƯỢNG >=30. 

THÀNH TIỀN = ĐƠN GIÁ * SỐ LƯỢNG + THUẾ + PHÍ VC. 

Sắp xếp theo thứ tự tăng dần của cột THÀNH TIỀN.
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Câu 5: Nhập dữ liệu, tính toán và lưu với tên Cau5.ods 

BẢNG TÍNH TIỀN ĐIỆN  tháng 4/2007 

STT HỌ VÀ TÊN CHỦ HỘ CSC CSM KW TĐIỆN VAT 
TỔNG 

CỘNG 

 Trần Thanh Bình 115 240         

 Phạm Trường Lâm 120 350         

 Phan Cẩm  Loan 161 421         

 Quách Thế Long 145 165         

 Trần Thị Hằng 225 320         

 Nguyễn Thị Tâm 142 178         

 Trần Văn Ngọc 125 156     

 Huỳnh Thanh Hoa 456 499     

 Lê Hoàng Tùng 431 488     

 Nguyễn Ngọc An 589 691     

 Trần Thanh Hồng 175 197     

 Lê Văn  Hùng 346 456     

 Nguyễn Hữu Chiến 124 156     

 Trần Văn Tâm 132 342     

 Lê Hữu  Hòa 357 451     

 Hồ Văn Lợi 751 851     

 Nguyễn Thị Lâm 478 567     

      

Mức tiêu thụ lớn nhất trong tháng: 

Mức tiêu thụ trung bình trong tháng: 

Mức tiêu thụ nhỏ nhất trong tháng: 

Cộng:  

   ? 

?
?
?
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Giải thích: CSC: Chỉ số cũ, CSM: Chỉ số mới, Tđiện: Tiền điện 

Yều cầu: 

Điền chuỗi số  thứ tự vào cột STT .  

KW : Mức tiêu thụ trong tháng tính bằng KW = CHỈ SỐ MỚI - CHỈ SỐ 
CŨ. 

TIỀN ĐIỆN = Số KW * GIÁ TIỀN ĐIỆN /KW, biết giá tiền điện là 
1200đ /KW 

VAT: 10% của TiềnĐiện.  

TỔNG CỘNG: Là tổng của TIỀN ĐIỆN và VAT. 

CỘNG = Tổng của cột TỔNG CỘNG 

Tìm  mức tiêu thụ lớn nhất trong tháng. 

Tìm  mức tiêu thụ trung bình trong tháng. 

Tìm  mức tiêu thụ nhỏ nhất trong tháng. 

Xếp theo thứ tự tăng dần của cột TỔNG CỘNG.
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Câu 6: Nhập dữ liệu, tính toán và lưu file  cau6.ods 

KẾT QUẢ TUYỂN SINH KHOÁ NGÀY 20/04/2007 

STT HỌ VÀ TÊN SBD 
Khu 

vuc 

Anh 

văn
Toán

Tin 

học
ĐiểmKV 

Tổng 

điểm 

Kết 

quả 

 Trần Đình Anh 346B 1 9 7 5    

 Bảo  Ngọc 890C 1 3 6 6    

 Bùi thi Thu  Cúc 342B 3 5 8 4    

 Nguyễn thị  Hằng 674B 2 7 8 4    

 Bùi văn  Tuấn 781B 3 4 3 5    

 Trần Bình Minh 201C 2 8 8 9    

 Trần văn  Hùng 459A 2 5 4 3    

 Bùi  Thanh 576C 2 7 6 4    

 Nguyễn thị  Thu 324A 1 7 8 4    

 Nguyễn văn  Anh 231A 2 6 3 4    

 Lê Văn  Hùng 142C 2 5 4 6    

 Nguyễn Hữu Chiến 231A 1 8 2 1    

 Trần Văn Thông 463C 2 2 5 4    

 Lê Hữu  Hòa 346C 3 6 4 8    

 

Tổng điểm thấp nhất:. 

Tổng điểm cao nhất:. 

Tổng điểm trung bình: 

Yều cầu: 

Điền chuỗi số  thứ tự vào cột STT .  

Tính các cột còn lại của bảng tính theo các qui tắc sau: 

ĐiểmKV : Nếu là Khuvuc 3 thì ĐiểmKV = 2, ngược lại ĐiểmKV = 1. 
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Tổngđiểm: là tổng các môn thi (Anh văn hệ số 1, Toán và Tin học có hệ 
số 2) và ĐiểmKV 

Kếtquả: Nếu TỔNG ĐIỂM bé hơn 25 thì ghi là “Thi lại”, ngược lại ghi 
“Đậu”. 

Tìm TỔNG ĐIỂM thấp nhất . 

Tìm TỔNG ĐIỂM cao nhất . 

Tìm TỔNG ĐIỂM trung bình. 

Sắp xếp cột TỔNG ĐIỂM theo thứ tự giảm dần. 
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Câu 7: Nhập dữ liệu, tính toán và lưu với bai7.ods 

BẢNG TÍNH TIỀN ĐIỆN  tháng 2/2007 

STT HỌ VÀ TÊN CHỦ HỘ CSC CSM KhuVực TỔNG CỘNG 

 Trần Thanh Bình 115 240 2  

 Phạm Trường Lâm 120 350 1  

 Phan Cẩm  Loan 161 421 3  

 Quách Thế Long 145 165 2  

 Trần Thị Minh Hằng 225 320 2  

 Nguyễn Thành Tâm 142 178 1  

 Trần Văn Ngọc 125 156 1  

 Huỳnh Thanh Hoa 456 499 2  

 Lê Hoàng Tùng 431 488 3  

 Nguyễn Ngọc Thanh 589 691 3  

 Trần Thanh Hồng 1754 1978 1  

 Lê Văn  Hùng 346 456 1  

 Nguyễn Hữu Chiến 1245 1564 2  

 Trần Văn Thông 132 342 2  

 Lê Hữu  Hoàng 357 451 1  

 Hồ Văn Lợi 751 851 1  

        

Cộng: 

Mức tiêu thụ lớn nhất trong tháng: 

Mức tiêu thụ trung bình trong tháng: 

Giải thích: CSC: Chỉ số cũ, CSM: Chỉ số mới. 

Yều cầu: 
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Thêm các cột KW, Vượt, Tđiện, Phạt, VAT sau cột trước cột Tổng 
Cộng 

Điền chuỗi số  thứ tự vào cột STT.  

KW : Mức tiêu thụ trong tháng tính bằng KW = CHỈ SỐ MỚI - CHỈ SỐ 
CŨ. 

Vượt: Số KW vượt định mức. Định mức số KW cho mỗi hộ là 120 KW 

TIỀN ĐIỆN = Số KW định mức * GIÁ TIỀN ĐIỆN /KW, biết giá tiền 
điện định mức của khu vực 1 là 800đ /KW. Các khu vực còn lại giá 
1000đ/kw 

PHẠT : Chỉ phạt những hộ có mức dùng vượt quá định mức. Mỗi KW 
vượt sẽ được tính 1500đ/kw cho tất cả các khu vực. 

VAT = 10% của TIỀN ĐIỆN và TIỀN PHẠT 

TỔNG CỘNG : Là tổng của TIỀN ĐIỆN, VAT và PHẠT. 

CỘNG = Tổng của cột TỔNG CỘNG 

Tìm  mức tiêu thụ lớn nhất trong tháng. 

Tìm  mức tiêu thụ trung bình trong tháng. 

Xếp theo thứ tự tăng dần của cột TỔNG CỘNG 
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Câu 8: Nhập dữ liệu, tính toán và lưu với tên cau8.ods 

BẢNG TÍNH TIỀN ĐIỆN Tháng 10/2006 

     Đơn giá 800 

STT 
LOẠI

SD 
CHỈ SỐ 
ĐẦU 

CHỈ SỐ  
CUỐI 

HỆ 
SỐ 

THÀNH
TIỀN 

PHỤ 
TRỘI 

CỘNG 

1 KD 34 62         

2 NN 58 350         

3 SX 90 150         

4 CN 150 700         

5 KD 400 650         

6 SX 50 90         

7 KD 345 546     

8 NN 454 511     

9 NN 786 904     

   Tổng cộng    

   Trung bình    

   Cao nhất    

   Thấp nhất    

 

DÒ HỆ SỐ 

LOẠI 
SD 

HỆ 
SỐ

LOẠI 

NN 1 Nông Nghiệp
KD 3 Kinh Doanh
SX 2.5 Sản Xuất
CN 2 Công Nghiệp 

Lưu ý: Trị 500 của ĐƠN GIÁ phải nhập vào một ô biệt lập. 
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Thêm vào cột LOẠI sau cột LOẠI SD. LOẠI được dò tìm trong bảng 
DÒ HỆ SỐ dựa vào LOẠI SD. 

Hệ số được dò tìm trong BẢNG DÒ HỆ SỐ, dựa vào LOẠI SD. 

Thêm vào cột KW sau cột HỆ SỐ. KW là định mức tiêu thụ điện trong 
tháng và =  CHỈ SỐ CUỐI - CHỈ SỐ ĐẦU. 

THÀNH TIỀN = KW * HỆ SỐ * ĐƠN GIÁ. 

PHỤ TRỘI = 0 nếu (CHỈ SỐ CUỐI - CHỈ SỐ ĐẦU ) <50 

PHỤ TRỘI = THÀNH TIỀN * 50% nếu  ngược lại.  

CỘNG = THÀNH TIỀN + PHỤ TRỘI và được làm tròn đến hàng trăm. 

TÍNH TỔNG CỘNG, TRUNG BÌNH, CAO NHẤT, THẤP NHẤT cho 
các cột . 

Xếp theo thứ tự giảm dần của cột CỘNG. 

Định dạng các cột số có dấu tách hàng ngàn. Kẻ khung và trang trí bảng 
tính.
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Câu 9:Nhập dữ liệu, thực hiện tính toán và lưu với tên cau9.ods 

BẢNG THANH TOÁN LƯƠNG THÁNG 10/2006 

  Hệ số lương: 120    

STT 
MÃ 
NV 

HỌ & TÊN LCB 
NĂM 
VÀO 

NGÀY 
CÔNG 

LƯƠNG 
PHỤ CẤP 
ĐỘC HẠI 

THỰC 
LÃNH 

  H01       25       

  D01       24       

  D02       28       

  S02       22       

  D03       29       

      Tổng cộng   

   Tính trung bình    

  

DANH SÁCH NHÂN VIÊN 

 
MÃ NV HỌ & TÊN LCB 

NĂMVÀ
O

 H01 Trần Thái 410 1992

 D01 Trịnh Sâm 350 1989

 D02 Trần Bình 300 1991

 D03 Châu Hà 280 1997

 S02 Phan Tiến 300 1995

Chú ý:  Giá trị 120 của Hệ số lương phải nhập vào một ô riêng 

Nhập dữ liệu cho bảng tính và bảng DANH SÁCH NHÂN VIÊN như 
trên. 

Các cột HỌ & TÊN, LCB, NĂM VÀO dò tìm trong bảng danh sách 
nhân viên, dựa vào MÃNV. 
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LƯƠNG = LCB*NGÀY CÔNG*HỆ SỐ LƯƠNG. 

PHỤ CẤP ĐỘC HẠI được tính dựa vào ký tự đầu của MÃ NV như sau: 

Nếu ký tự đầu của MÃNV là D (Độc hại) thì phụ cấp ĐH = 30*LƯƠNG. 

Còn ngoài ra thì không phụ cấp độc hại. 

THỰC LÃNH = LƯƠNG + PHỤ CẤP ĐỘC HẠI 

TỔNG CỘNG = Cộng của cột THỰC LÃNH. 

Trang trí và kẻ khung bảng tính – Định dạng các cột dữ liệu số có dấu 
tách hàng ngàn. 

Các cột STT, MÃ NV, LCB, NĂM VÀO, NGÀY CÔNG được canh 
giữa. 

Tính giá trị trung bình của các cột LƯƠNG, PHỤ CẤP ĐỘC HẠI, 
THỰC LÃNH 

Dựa vào kết quả của câu 9, vẽ biểu đồ biểu diễn kết quả trung bình của 
các LƯƠNG, PHỤ CẤP ĐỘC HẠI, THỰC LÃNH 
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Phụ lục: Những khác nhau cơ bản giữa Calc và Excel 

 Các tham số khác nhau trong hàm 

Điều khác nhau cơ bản nhất giữa Calc và Excel là Calc luôn luôn 
dùng dấu chấm phẩy (;) để chỉ các tham số khác nhau trong một hàm. 
Excel sử dụng dấu phẩy hoặc dấu chấm phẩy, tùy thuộc vào hệ thống (ví 
dụ như dấu phẩy trên các hệ thống tiếng Anh, dấu chấm phẩy trên các hệ 
thống tiếng Đức). 

 Thuật ngữ 

Sự khác nhau tiếp theo giữa Calc và Excel là việc sử dụng thuật 
ngữ, bảng sau sẽ tổng kết những điểm khác nhau đó 

Đối tượng Excel Calc 

Một ô riêng (A1) Ô Ô 

Toàn bộ tập tin Sổ làm việc Bảng tính 

 Danh sách phạm vi 

Excel cho phép tất cả các tham số có thể là danh sách phạm vi 

Ví dụ: = SUM (A1;A3) là tổng của hai ô (gồm 2 tham số) 

= SUM ((A1;A3)) tương tự trên nhưng chỉ với một tham số trở 
thành danh sách phạm vi 

= INDEX ((A2:A3;C2:C3),1,1,2) 

Calc chỉ cho phép danh sách phạm vi trong một hàm INDEX. Ví dụ 

= INDEX ((A2:A3;C2:C3);1;1;2) trả về ô đầu tiên của hàng thứ hai 
trong danh sách phạm vi 

 Thông dịch nội dung các ô 

Trong Calc nếu một ô được định nghĩa kiểu văn bản, thậm trí nếu ô 
chứa nội dung là số, thì sau đó ô được xem như kiểu văn bản đặc biệt có 
giá trị là số 0. 

Ví dụ: nếu ô A1 được định dạng là văn bản và nội dung của nó 
chứa ký tự “1”, trong Excel là công thức = A1+1 sẽ trả về giá trị là 2, 
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nhưng trong Calc nó sẽ trả về giá trị 1. 

 Giới hạn 

Số bảng tính lớn nhất trong Calc là 256, Execl có số bảng tính lớn 
nhất là 32768. 

 Định dạng các trường 

Các hộp danh sách trong Calc có thể có nhiều lựa chọn hoặc không, 
ngược lại trong Excel có hai phương thức để chọn nhiều: dạng nhiều và 
mở rộng. Trong Excel đường liên kết hộp danh sách nhiều lựa chọn tới 
một ô bị lờ đi. Trong Calc đường liên kết hoạt động nhưng nếu có nhiều 
hơn một mục được lựa chọn thì giá trị của ô được đặt là #N/A. 

Trong Calc mỗi nút bấm option có một đường liên kết tới các ô, 
việc thiết lập giá trị là đúng hoặc sai tùy thuộc vào optinon có được lựa 
chọn hay không. Trong Excel đường liên kết ô trả về số nút bấm option 
được chọn. 

 Địa chỉ hóa các bảng tính 

Trong Calc có khả năng địa chỉ hóa các bảng tính. Giống như việc 
tham chiếu với cột và ô, dấu $ được sử dụng làm ký hiệu xác thực tên 
bảng tính. 

=$Bang2!$A$1 luôn chỉ tới ô đầu tiên trong bảng tính 2. 

=Bang2!$A$1 khi trên một bảng tính và được sao chép tới một 
bảng tính khác sẽ chỉ tới ô đầu tiên của bảng tính tiếp theo. 

Excel không có khả năng như vậy. 

 Công thức kiểu mảng 

Calc hỗ trợ các công thức tính kiểu mảng (các công thức được đưa 
ra bằng cách dùng tổ hợp phím Control + Shift + Enter), nhưng Calc 
không có mảng các hằng số trong một công thức. Công việc theo vòng 
tròn (work-around) là để có một giá trị không đổi trong các ô trên một 
bảng tính và tham chiếu tới chúng. 

Một vài công thức mảng trong Excel dường như dựa vào cách 
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Excel tính toán ra một kết quả không theo trong tài liệu, như vậy giống 
như một thói quen không tốt thậm trí chỉ trong Excel, và tất nhiên là một 
ý kiến không tốt khi nhập một tệp chứa một cách thức giống như vậy 
trong Calc. 

 Các tham số không bắt buộc trong các công thức 

Một vài công thức có nhiều tham số tùy chọn lại phần cuối của 
danh sách tham số. Trong Excel có khả năng bỏ đi một tham số tùy chọn 
nghĩa là có thể để trống nó và chỉ rõ tham số tiếp theo, nhưng trong Calc 
khôg có khả năng này. 

Ví dụ để tính tiền trợ cấp hàng năm: trong Excel công thức là = 
PV(0.05;10;100;;1) trả về giá trị 810.78; trong Calc =PV(0.05;10;100;;1) 
trả về lỗi Err:511. 

 Các biểu đồ 

Các kiểu biểu đồ mà Excel cung cấp, còn Calc thì không: 

- Thanh bằng hình tròn (Bar of pie) chuyển đổi thành 2D – các cột 
trụ – pháp tuyến. 

- Hình tròn bằng hình tròn chuyển đổi thành 2D – các cột trụ – pháp 
tuyến. 

- Radar với markers – chuyển đổi thành 2D – lưới – pháp tuyến 
nhưng bộ đếm theo chiều kim đồng hồ đúng hơn so với trong Excel. 

- Biểu đồ bọt chuyển đổi thành biểu đồ XY 

- Các biểu đồ Surface chuyển đổi thành biểu đồ thanh theo chiều 
sâu 3D. 

Các biểu đồ khác được đưa ra dưới đây 

- So với Excel các biểu đồ trong Calc được cập nhật chậm hơn. 

- Có một vài các tùy chọn về trục, dường như không có tùy chọn để 
có trục y đảo ngược (ngược lại theo hướng dương tại điểm giữa). 

- Dữ liệu phải giáp nhau với các nhãn trong dòng hoặc cột đầu tiên 
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 Các kiểu và việc định dạng cửa sổ 

Calc có hai loại ô và trang. Nhấn chuột phải trong các kiểu và việc 
định dạng cửa sổ đẻ tạo, sửa đổi, hoặc xóa các kiểu. 

 In ấn 

Calc và Excel có chức năng in giống nhau, nhưng vị trí của các 
thiết lập khác nhau không đáng kể. 

Theo mặc định Excel chỉ in những bảng tính động, trái lại Calc theo 
mặc định sẽ in toàn bộ các bảng tính. Nếu bạn chỉ muốn in một phần của 
các bảng tính, đầu tiên cần chỉ tõ phạn vi in. 

Để tiến hành in: 

- Chọn File → Print 

- Nhấn vào Optinons để thay đổi thiết lập cho các trang trắng hoặc 
chỉ những bảng tính được chọn. 

- Các thiết lập khác giống như trong Excel 
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